Friday 4 September 2020

When CoronaVirus hits someone..

 



🙄🙄🙄😫

It was a joke huh..your IQ is 8000

Lenovo releases first Fedora Linux ThinkPad laptop

 Fedora, Red Hat's community Linux for developers, is finally available from a mainstream PC vendor, Lenovo.


For years, ThinkPads, first from IBM and then from Lenovo, were Linux users' top laptop pick. Then, in 2008 Lenovo turned its back on desktop Linux. Lenovo has seen the error of its ways. Today, for the first time in much too long, Lenovo has released a ThinkPad with a ready-to-run Linux. And, not just any Linux, but Red Hat's community Linux, Fedora.



Source : https://www.zdnet.com/google-amp/article/lenovo-releases-first-fedora-linux-thinkpad-laptop/

Xbox Series X tech will supercharge Windows 10 PCs — here's how

 

Xbox Series X storage tech is coming to Windows 10

(Image credit: Xbox)

While it may have 12 teraflops of graphics power, one of the best features of the Xbox Series X will be its speedy SSD storage that promises to eliminate game load times. And that feature is coming to Windows 10 PCs. 

Source : https://www.tomsguide.com/amp/news/xbox-series-x-tech-will-supercharge-windows-10-pcs-heres-how

United states test launches intercontinental ballistic missile.

The US has launched an unarmed Minuteman III intercontinental ballistic missile, equipped with a test reentry vehicle, from Vandenberg Air Force Base in California.


Source : 

Thursday 3 September 2020

what is robots.txt and how to make perfect robots.txt file.

web crawler first checks robots.txt file . 

robots.txt file gives information to web crawler about on what pages to crawl and on what pages not to crawl.

this saves so much time of web crawler so crawler can easily crawl your website.

and it optimizes SEO .

It makes your website easily available on search engine very fast.

you can add custom robots.txt in your website's code.

you can check your robots,txt file by just typing the URL   your website url/robots.txt/

Here is the explanation by Neil Patel.

https://neilpatel.com/blog/robots-txt/

pic : neilpatel.com

robots

Supreme Subset (1 D & Data Structures Practice Problems) | hackerearth

Wednesday 2 September 2020

Vowel Recognition Sum of vowels in all substrings of a string.#hackerearth | using prefix_sum | Python.. and in C++

 Natural Language Understanding is the subdomain of Natural Language Processing where people used to design AI based applications have ability to understand the human languages. HashInclude Speech Processing team has a project named Virtual Assistant. For this project they appointed you as a data engineer (who has good knowledge of creating clean datasets by writing efficient code). As a data engineer your first task is to make vowel recognition dataset. In this task you have to find the presence of vowels in all possible substrings of the given string. For each given string you have to print the total number of vowels.

Input First line contains an integer T, denoting the number of test cases. Each of the next lines contains a string, string contains both lower case and upper case . Output Print the vowel sum Answer for each test case should be printed in a new line. SAMPLE INPUT 1 baceb SAMPLE OUTPUT 16 Explanation First line is number of input string, In given example, string is "baceb" so the substrings will be like -"b, ba, bac, bace, a, ac, ace, aceb, c, ce, ceb, e, eb, baceb" now the number of vowels in each substring will be 0, 1, 1, 2, 1, 1, 2, 2, 0, 1, 1, 1, 1, 2 and the total number will be sum of all presence which is 16.


Here is the solution in python using prefix sum approach..this is my you tube chennal..



in C++ :

#include<bits/stdc++.h>
using namespace std;
int main() {
int t, arr[10] = {'A','E','I','O','U','a','e','i','o','u'},len;
long int count;
string s;
cin >> t;
while(t--) {
count = 0;
cin >> s;
len = s.length();
long int ps_arr[len]; int i=1;
ps_arr[0] = len;
while(i<len) {
ps_arr[i] = (len-i)+ps_arr[i-1]-i;
i++;
}
i = 0;
while(i<len) {
if(find(arr,arr+10,s.at(i)) != arr+10) {
count += ps_arr[i];
}
i++;
}
cout << count << "\n";
}
}